Grey matter segmentation CSV: Vert Level Missing

Hi @Mohammed_KHAMAYSA,

Sorry for the late response. Have you run vertebral labeling on your data?

If you share your analysis script that includes all the commands you ran, we will be able to find out where the problem is.


Hi @jcohenadad
Sorry for the late response. I did vertebral labeling on my data. I am attaching the script I used for the analysis after adapting the stranded
many thanks for taking the time to check it (7.4 KB) bash script


This line is problematic:

sct_register_multimodal -i /home_local/mkhamays/sct_testing_data/mt/label/template/PAM50_t2s.nii.gz -iseg /home_local/mkhamays/sct_testing_data/mt/label/template/PAM50_wm.nii.gz  -d t2s.nii.gz -dseg t2s_wmseg.nii.gz -param step=1,type=seg,algo=rigid:step=2,type=seg,algo=bsplinesyn,slicewise=1,iter=3 -initwarp ../t2/warp_template2anat.nii.gz -initwarpinv ../t2/warp_anat2template.nii.gz

You cannot use an already-registered PAM50 from the testing data and then run sct_warp_template (which assumes the original PAM50, not the one registered under the testing data).

So in this case, what you want to do is:

sct_register_multimodal -i $SCT_DIR/data/PAM50/template/PAM50_wm.nii.gz -d t2s_wmseg.nii.gz -dseg t2s_seg.nii.gz -param step=1,type=im,algo=syn,slicewise=1,iter=5 -initwarp warp_template2t2s.nii.gz -initwarpinv warp_t2s2template.nii.gz

Note that you have the same issue later, at line 116:

sct_register_multimodal -i /home_local/mkhamays/sct_testing_data/mt/label/template/PAM50_t1.nii.gz -iseg /home_local/mkhamays/sct_testing_data/mt/label/template/PAM50_cord.nii.gz  -d dwi_moco_mean.nii.gz -dseg dwi_moco_mean_seg.nii.gz -param step=1,type=seg,algo=centermass:step=2,type=seg,algo=bsplinesyn,slicewise=1,iter=3 -initwarp ../t2s/warp_template2t2s.nii.gz -initwarpinv ../t2s/warp_t2s2template.nii.gz

I strongly recommend you do all the tutorials to make sure you understand all the steps involved in the analysis, before modifying the example batch processing script.

I also recommend you keep the flag ā€œ-qcā€ so you can perform convenient QC on your processing.

Please let me know if you have additional questions,