Co-registering mt0 with mt_t1 error

Hello!

I am registering mt1 and mt0 to mt_t1 to calculate both MTR and MTsat maps later. While mt1 co-registers to mt_t1 space fine, mt0 does not. I assume this is because of the poor contrast on mt0.

I’ve tried algo=rigid and algo=slicereg (screenshot attached) but both were not good.

I tried experimenting with metric=MI instead of metric=CC but this did not resolve the issue either. Cord segmentation of mt0 using sct_deepseg_sc was also not good; thus, other algo parameters (seg only) did not work too.

Do you have any suggestion on what I could try to fix the registration so I don’t have to lose this data?

Thank you!

Sincerely,
Lisa

Hi Lisa,

I’m very sorry for the late reply. We had issues with the notification system of this forum. Anyway, I’m here now :blush:

So: your diagnosis is correct: the co-registration is failing because of the relatively poor contrast between the cord and CSF on the MToff data.

The algo you used are good. Slicereg being probably the most reliable.

Few questions/comments:

  • have you tried changing the size of the mask derived from the MTon data?
  • do you experience registration issue on most of your subjects? or only a small fraction? I assume this dataset is from Siemens, and you’re mostly experiencing issues with Siemens protocol (because contrast is better on Philips scans).
  • we have a new registration algorithm based on deep learning. Maybe you’d like to give it a try? it’s called algo=dl and it is available as of SCT v5.7 (see details here).