Error running v4.0.0-beta.2

Hi developers:

My SCT scripts run perfectly fine in v.3.2.7 and so I downloaded the newest version v4.0.0-beta.2 to compare the results. Unfortunately, after installation of v4.0.0-beta.2 I get an error running my first script, sct_deepseg_sc. The output is as follows:

barryrl% sct_deepseg_sc

/Applications/SCT/ver_4_0_0_beta_2/bin/sct_launcher: line 79: /Applications/SCT/ver_4_0_0_beta_2/python/bin/activate: Too many levels of symbolic links
[WARNING] using system python, /Applications/SCT/ver_4_0_0_beta_2/python/bin/activate not found

Spinal Cord Toolbox (version: 4.0.0-beta.2)
Running /Applications/SCT/ver_4_0_0_beta_2/scripts/
Traceback (most recent call last):
File “/Applications/SCT/ver_4_0_0_beta_2/scripts/”, line 19, in
import sct_utils as sct
File “/Applications/SCT/ver_4_0_0_beta_2/scripts/”, line 27, in
import portalocker
ImportError: No module named portalocker
Total processing time: 0 min 0 s

I tried installing again into a different directory, and then onto a different computer, and got the same error message. I took a closer look at the symbolic link that it is complaining about, and noticed that in the /python/bin directory there are subfolders /activate, /conda, and /deactivate that are actually symbolic links that point to themselves (i.e., recursively). These three recursive subfolders do not exist in the /python/bin subfolder in ver 3.2.7.

I tried deleting these three infinitely recursive subfolders but then I got the following error message:

barryrl% sct_deepseg_sc

/Applications/SCT/ver_4_0_0_beta_2/bin/sct_launcher: line 79: /Applications/SCT/ver_4_0_0_beta_2/python/bin/activate: No such file or directory
[WARNING] using system python, /Applications/SCT/ver_4_0_0_beta_2/python/bin/activate not found

Is there a way that I can easily fix this so I can try out the newest version?



Hi Rob
Sorry about this issue. Could you please try to git clone the master branch and run the install for there?

Thanks, Julien. I cloned the master branch and ran install_sct. The install apparently failed, and the instructions asked me to post the output on the forum (text file attached). However, importantly, the three infinitely recursive subfolders do not exist in /python/bin when installed this way. Thanks!

SCT_installation_2019-04-16_failed.txt (46.6 KB)

Hi Rob,
this bug (in is related to a recent change (we are working on it), but it should not affect the behaviour of SCT. Could you please open a new Terminal and run the full testing:



Hi Julien,

Thanks for the follow-up. I ran sct_testing and all scripts passed their respective tests!