Failed Installation on macOS Big Sur Version 11.6.1

Dear SCT team!
I am having trouble with the SCT installation on MacOS Big Sur Version 11.6.1.
I am trying to install SCT 5.2. Attached is the screenshot of the error message. Thank you for your help.


  1. A description of the problem. (What are trying to do? What did you expect to happen? What actually happened?)
  2. Commands and terminal output. (What are the exact commands you used? Please copy and paste the full output of the command from your terminal.)
  3. System information. (Please run the command “sct_check_dependencies” in your terminal, then copy and paste the output.)
  4. File upload. (Please upload any data or scripts needed to reproduce your issue, if there are any.) →

Hi @Mfauziyya ,

It looks like you double-clicked on the installer from the Finder window. Could you instead:

  • Open a Terminal,
  • cd to the directory where SCT is downloaded
  • type “./install_sct”

Let us know how it goes

Hi Dr Cohen-Adad,
I tried to install through the Terminal and the problem with SCT still persists. Please see the attached terminal txt output. It said activation of venv_sct failed. I tried ‘$ condo activate vent_sct’ or ‘$ conda deactivate’ before running the ‘install_sct’, but the problem still persisted.
I ran these commands ‘which python’
‘which pip’

                                 'source $SCT_DIR/python/etc/profile.d/'
                                 'conda activate vent_sct'
                                 'which python'
                                 'which pip'

Here is the output:
nesh4tgl0yfpn7c:~ Fmuhamma$ which python
nesh4tgl0yfpn7c:~ Fmuhamma$ which pip
nesh4tgl0yfpn7c:~ Fmuhamma$ source $SCT_DIR/python/etc/profile.d/
-bash: /python/etc/profile.d/ No such file or directory
nesh4tgl0yfpn7c:~ Fmuhamma$ conda activate venv_sct
-bash: conda: command not found
nesh4tgl0yfpn7c:~ Fmuhamma$ which python
nesh4tgl0yfpn7c:~ Fmuhamma$ which pip

Thank you for your help,

It is possible that it is related to a bug that has since been fixed. Could you please try installing the latest version of SCT?

Thank you for responding. I tried to install SCT version 5.6, attached is the error message.
install_sct_log.txt (15.2 KB)


Hi @Mfauziyya,

We have opened a GitHub Issue (#3800) to track the development of a fix for this problem.

To help debug the problem, I have made a new version of the install_sct script that includes some debugging commands:

install_sct_debug (25.5 KB)

Could you please download this script, copy it inside the spinalcordtoolbox-5.6 folder, then run the script with -v (verbose) by typing:

./install_sct_debug -v

Then, please share the new install_sct_log.txt file again. :slight_smile:

Thank you kindly,

Hi Joshua,
Thank you for your help. Looks like the SCT installed correctly with the new script.
install_sct_log.txt (95.7 KB)

I will try our analysis code, I hope it will run correctly this time.


1 Like

Hi @Mfauziyya,

Thank you for testing this for us! Your installation logs help us greatly in fixing the issue for future users.

Looks like the SCT installed correctly with the new script.


As well, I can happily report that the error you encountered previously was a non-critical error (see this analysis). So, your installation of SCT should be good to use. :slight_smile:

If you happen to encounter any other issues, or if you have any questions or concerns, feel free to make a new post and we’ll be happy to help.

Kind regards,