FSLeyes Integration Script Error

I have FSL installed onto my system and have now installed SCT. I was hoping to integrate SCT and FSLeyes using the sct_plugin.py script. However, when I tried, I received the following error:

The script /Users/waldmanad/sct_5.8/contrib/fsl_integration/sct_plugin.py has crashed! Reason: Rect.SetHeight(): argument 1 has unexpected type ‘float’

Any thoughts on where I may be going wrong? Thanks!

1 Like

Hi @AW123,

To understand your FSLeyes installation better, could you please run the following commands in your terminal, then share the outputs?

which fsleyes
fsleyes --version

Could you also share which operating system you are using? (Ubuntu 22.04, macOS 10.15, macOS 11, etc.)

Thank you kindly,

1 Like

Thanks, @joshuacwnewton!

I am using a macOS Monterey Version 12.6.2.

The commands gave the following outputs:

fsleyes/FSLeyes version 1.5.0

1 Like

Thanks much for the reply, @AW123!

I have tried reproducing this error on my local machine using FSLeyes v1.5.0, but the SCT script works for me.

I am running Linux (Debian 11), so it’s possible that this may be a macOS 12-specific issue. I’ll take a look using a macOS machine next.

For now, I have opened an issue in the SCT GitHub Repository, and this issue will be looked at with high-priority. :slight_smile:

Thank you again for reporting this issue!

1 Like

Just to clarify one last thing:

Does the error happen when first loading the script? Or, does the error occur when trying to perform some sort of action within FSLeyes (like pressing a button, running an SCT command, etc.)?

1 Like

Thanks! The error happens when first loading the script.

As more background, I first downloaded FSL with the new installation script (https://fsl.fmrib.ox.ac.uk/fsldownloads/fslconda/releases/fslinstaller.py) though I had to use an older version of mambaforge (https://github.com/conda-forge/miniforge/releases/download/4.14.0-0/Mambaforge-MacOSX-x86_64.sh) because newer ones kept throwing the following error:

/Users/waldmanad/fsl/preconda.tar.bz2: No such file or directory

I then downloaded SCT successfully via the command line, loaded FSLeyes from the command line, and tried the integration script which threw the error.


Hi @AW123 ,

After downloading SCT, did you also installed SCT? (by launching the command ./install_sct as instructed here)?


1 Like

Yes, it’s installed and all looked like it was successful (I didn’t notice any errors).

Thank you for checking @AW123, we keep investigating this bug.

Good news, @AW123! We have been able to reproduce this issue:


We have determined that the bug is actually inside of FSL. There is a problem with the wxPython software package that FSL v6.0.6 uses. The good news is, the wxPython bug was fixed here: PR #1896. This means that all you need to do is update the version of wxPython inside of FSL.

You can update wxPython using the following command:

sudo $FSLDIR/bin/conda update -n base wxPython

You should see wxPython updated from v4.1.1 to v4.2.0. After updating, the SCT FSLeyes integration should work correctly.

Thank you again for bringing this to our attention! We greatly appreciate your contribution on the forum. :blush:

Kind regards,