Installation failed in MacOs M1

Installation failed
MacOS M1

Hi @Spine,

To help us debug your issue, could you please copy the full output of the “./install_sct” command and paste it here?

Thank you kindly,

Hi @Spine,

We’ve already resolved this in a previous issue, where I showed the installation procedure I followed to successfully installing in a MacOS M1: Issue to Install SCT on MAC M 1

Please let me know if you’ve already tried this, and if so, let us know of the different error you are experiencing.

1 Like

Hi again @Spine,

So I just double-checked that the current version of SCT is still working with M1 by following my old instructions (from May), and it appears that I too encounter an error now. Here’s a screen-captured video of all my steps:

I think that a recent change in requirement dependencies for Keras and Tensorflow might be the root cause of this:

I tried the installation again, but by first checking out the commit from May 26 (c951389c917884e7e3bb3c3f39aea47669a07a79), and this time the installation worked. See video here:

So, as a temporary measure, you could try doing git checkout c951389c91788 and the test the installation again, as long as you also have Anaconda and your shell is bash, as I did in my first video.

I think the developers might have some additional information to share with you regarding this.

p.s. If you encountered a different error than I did, please let us know.

Thanks for you support.
SCT worked.

1 Like