Installation Failed.. :( Write Permission?

Hello Everyone!
I am new to the forum and new to SCT. I’m a complete noob with this stuff! However, with a case of spinal MS myself, I’m interested to see how this works out.
I ran into a terminal installation issue this morning running OSX 10.13.6 attempting to install SCT4.3.
The following warning came up, I’m sure it’s a simple fix, but I’m very new to Terminal. Many thanks in advance!

(mp)/sct_4.3 cannot be created. Make sure you have write permission.

Installation failed!

How do I go about gaining write permission? Thanks again!!! Cliff

Hi Cliff,

Could you please copy/paste your terminal history, so we know exactly what commands you’ve executed, and where?


Yes sir, Thank you for the quick reply.
I am trying a few other things first.

Please see the terminal response.
I read in another forum posting to run the source folder outside of the applications folder, so that’s what I am attempting to do.

@AmITrippen I see that you have spaces " " in your directory trees. Spaces should be avoided when working with Unix systems (Linux and OSX). Could you please replace those spaces by e.g. underscores “_” and re-run the command?


Thanks for the quick reply. I created a new user (admin) to clean up the spaces. Still having issues with the version.txt file. Take a look at the shots and see what you make of it. Thank you again!!

Hi Cliff,

Looks like the files you are trying to use are somewhat corrupted. Since I don’t know how you downloaded the files (and what manipulations you did), I would suggest to start fresh. Can you please open a Terminal and run the following commands:

cd ~
curl -o -L
cd spinalcordtoolbox-*
yes | ./install_sct 

Let me know how it goes

Hi Julien,
Well I got a lot farther than before, so the info you provided worked. However, the install failed. Check out the terminal report.
Looks like a requirements issue?

I need to know which OS version you are running. Could you please rerun the installation and copy/paste the entire terminal output. You can copy the text instead of taking a screenshot.

Hello Julien,
Thanks for helping. Below is the terminal record of the most recent install attempt. Please let me know if you need anything else. :slight_smile: I have attached a textedit doc with the terminal report because the report exceeded the character allotment of this post.

system 07122020.rtf (73.9 KB)

There seem to be some internet connection problems. The connection to miniconda server failed several times, and when it worked, a file got corrupted. What country are you based at?

I am based in Texas, in the United States. I do have to use my LTE connection for internet where I live because there is no local ISP available. It’s spotty at times, but not usually a problem.
I’m going to give a shot again and see what happens. Thanks for the help so far.

Hello Julian,
I hardwired the LTE router into my Mac, ran your script and that helped with a full install. Terminal reports a successful installation. I’m going to attempt to launch the program and give a try today. I will let you know how it goes. Thank you for being so responsive and helping me with these issues. VERY much appreciated. :slight_smile:

1 Like