Installing SCT on Mac (M1) OS Version 13.0

I am having difficulty installing SCT on my MacBook Pro OS 13.0.

The beneath error keeps showing up:

Installing Miniconda...

bash /var/folders/d7/6n0293712vb_3j2xk6g5_00r0000gn/T/tmp.GRy89ac8/ -p /Users/omid/spinalcordtoolbox/python -b -f

Unpacking payload ...
/var/folders/d7/6n0293712vb_3j2xk6g5_00r0000gn/T/tmp.GRy89ac8/ line 405: /Users/omid/spinalcordtoolbox/python/conda.exe: Bad CPU type in executable
/var/folders/d7/6n0293712vb_3j2xk6g5_00r0000gn/T/tmp.GRy89ac8/ line 408: /Users/omid/spinalcordtoolbox/python/preconda.tar.bz2: No such file or directory

ERROR: Command failed.

Installation failed!

Please find the file "/Users/omid/spinalcordtoolbox/install_sct_log.txt",
then upload it as a .txt attachment in a new topic on SCT's forum:

I tried to install Miniconda independently but I got this error again.

Hi @omidetemadi,

Thank you for your question on the forum. We would be happy to help. :slight_smile:

This error appears to be due to missing Rosetta on your M1 Mac. (Rosetta is used for backwards compatibility on apps that are not designed for M1 Silicon.)

Could you please try installing Rosetta using the command below, then re-running the SCT installer?

softwareupdate --install-rosetta

Kind regards,

Additionally, if the installation fails again, can you please share the file “/Users/omid/spinalcordtoolbox/install_sct_log.txt” that is created during the installation process?

This will provide us with the full install log, which will help us to debug the problem further. :slight_smile:

Kind regards,

Thank you. My problem was solved with your solution.

1 Like