Sct_register_to_template: no response

Dear experts in SCT team,
I’m trying to register my T2 images to template. It was done well when I tried to register them to the template. However, my images are highly anisotropic resolution (3mm thickness) and I tried to register the template to the subject space (by -ref subject) the process seemed to stop in a process of “Estimate transformation” and no further response afterwards. I wonder if it’s because the computer is not powerful enough or the parameter should be adjusted.

Please see the attached files:

I would be grateful for your reply, thanks.


Indeed, using -ref subject is very slow in your case because the sagittal in-plane resolution is 0.36mm (images are interpolated), so that’s a lot of voxels to compute the transformation on. Moreover, we don’t recommend this approach for sagittal data because the spinal cord it not straightened (and it should be, for large coverage sagittal scans).

Using the default syntax works fairly well:

sct_register_to_template -i t2.nii.gz -s t2_seg.nii.gz -l t2_labels_vert.nii.gz -qc qc


Hi Julien,
Thank you for your prompt reply. It is very helpful to me.

Best regards,

1 Like